Welcome

M9216A PXI
High Voltage DAQ

LabVIEW G Programming Information

This help file contains the LabVIEW G programming information for the M9216A PXI High Voltage DAQ.

  • Introduction
  • Programming Examples
  • Method (VI) Reference
  • Related Documentation

© Agilent Technologies, Inc. 2011

Version 1.0


Introduction

Introduction to the AgM9216 LabVIEW Driver

The AgM9216 LabVIEW Driver allows you programmatic control for the M9216A PXI High Voltage DAQ. The Agilent M9216A PXI High Voltage DAQ his specifically designed for automotive electronics voltage measurements.It has eight internal semi-autonomous 16-bit 250 kSa digitizers (channels), and at the front end, a 32 input port multiplexer capable of withstanding voltages of up to 100 V. The M9216A slots into a standard PXI frame and physically occupy two slot spaces. It works with a 5.0 V or 3.3 V signaling level and is compatible to PXI- 2.

See Also:
  • Agilent M9216A product website
  • Block diagram
  • VI descriptions
  • Examples
  • Related documentation


M9216A Block Diagram

Block diagram of M9216A in Multiple Channel mode

Block diagram of M9216A in Single Channel mode


Scenarios and Sample Programs

Programming Examples for the AgM9360 LabVIEW Driver

The following example programs are provided to demonstrate most features in the M9216A PXI High Voltage DAQ. Each example VI has a front panel you can use to exercise the underlying VI functions.

  • Multiple Mode Meas AUX Enabled
  • Multiple Mode Measurement
  • Single Mode Measurement


Agilent M9216-Multiple Mode Meas AUX Enabled.vi

Multiple Mode Meas AUX Enabled

This example first initializes the instrument reads a few Identity interface properties and perform instrument specific functionality for multiple mode measurement with bank1 Auxilary Enable.

Agilent M9216-Multiple Mode Meas AUX Enabled.vi


Agilent M9216-Multiple Mode Measurement.vi

Multiple Mode Measurement

This example first initializes the instrument reads few Identity interface properties and perform instrument specific functionality for multiple mode measurement.

Agilent M9216-Multiple Mode Measurement.vi


Agilent M9216-Single Mode Measurement.vi

Single Mode Measurement

This example first initializes the instrument reads few Identity interface properties and perform instrument specific functionality for single mode measurement.

Agilent M9216-Single Mode Measurement.vi


Methods

This section provides detailed descriptions of the Agilent M9216A LabVIEW driver VIs.

See Also:
  • Programming examples
  • M9216A block diagram


Agilent M9216.lvlib:SetAttributeViBoolean.vi

SetAttributeViBoolean

Sets a Boolean attribute from the instrument driver.

The following Attributes are supported:

SIMULATE

SYSTEM_TRACE_ENABLED

CHANNEL_AUX_OUT_ENABLED

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

SYSTEM_TRACE_ENABLED : If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. A new file is generated each time tracing is enabled.

CHANNEL_AUX_OUT_ENABLED : Set this property to true to switch the currently selected input port of the channel to auxillary output port of the digitizer. A true setting is not allowed in AgM9216MeasurementModeSingle mode.

cbool

AttributeValue (Off)

The value to which to set the property.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:SetAttributeViInt32.vi

SetAttributeViInt32

Sets an Int32 attribute from the instrument driver.

The following Attributes are supported:

TRIGGER_MODE

MEASUREMENT_MODE

CHANNEL_RECORD_SIZE

CHANNEL_INPUT_PORT

CHANNEL_INPUT_CONNECTOR_SELECTION

TRIGGER_HOLD_OFF_COUNT

TRIGGER_TIME_OUT

TRIGGER_PRE_TRIGGER_SAMPLES

TRIGGER_DELAY

TRIGGER_SLOPE

MEASUREMENT_RANGE_SELECT

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

TRIGGER_MODE : Sets the trigger mode either Channel (0) or Immediate (1).

MEASUREMENT_MODE : Sets the measurement mode either Single(0) or Multiple(1).

CHANNEL_RECORD_SIZE : Sets the acquisition recordSize of the Input connector of the channel.The allowable range is from 0 to 30000 in Multiple Channel and 0 to 240000 in Single Channel mode. Reset value is 5000.

CHANNEL_INPUT_PORT : The active (physically switch) port number(1 to 32) belonging to the channel (digitizer).

CHANNEL_INPUT_CONNECTOR_SELECTION : Sets the input connector.In Multiple mode, there are four (1 to 4) input connectors for each channel while in Single mode there are thirty two (1 to 32) connectors.

TRIGGER_HOLD_OFF_COUNT : Sets the count of valid edges that are detected before triggering is achieved.The allowable range is from 1 to 255.Reset value is 1.

TRIGGER_TIME_OUT : Sets the maximum time allowable to achieve trigger.The allowable range is from 1 to 16000000 us(16 s).Reset value is 1000000 (1 s).

TRIGGER_PRE_TRIGGER_SAMPLES : Specifies the number of samples that must be collected before a trigger event will be recognized.The allowable range is from 0 to RecordSize.Reset value is 0.

TRIGGER_DELAY : Sets the trigger hold off time.The allowable range is from 0 to 16000000 us.Reset value is 0 us.

TRIGGER_SLOPE : Sets the edge type for the trigger.

Positive : Configures trigger on the Positive slope.

Negative : Configures trigger on the Negative slope.

Both : Configures trigger on the both.

Level : Configures trigger on the DC level slope.

MEASUREMENT_RANGE_SELECT : Selects which waveform data from the 5V and 100V sub channels of the digitizer will be fetched to the driver after completing acquisition

0 : MeasurementRangeSelectLow

1 : MeasurementRangeSelectHigh

2 : MeasurementRangeSelectBoth

3 : MeasurementRangeSelectNone

ci32

AttributeValue

The value to which to set the property.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:SetAttributeViReal64.vi

SetAttributeViReal64

Sets a Real64 attribute from the instrument driver.

The following Attributes are supported:

TRIGGER_LEVEL

TRIGGER_HYSTERESIS

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

TRIGGER_LEVEL : Sets the trigger level in voltage for the current selected connector.The allowable range is from 0.0V to 100.0V.Reset value is 1.0 V.

TRIGGER_HYSTERESIS : Sets the trigger level hysteresis in voltage for the currently selected connector.The allowable range is from 0.0 V to 0.5 V.Reset value is 0.0001 V.

cdbl

AttributeValue

The value to which to set the property.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:GetAttributeViBoolean.vi

GetAttributeViBoolean

Gets a Boolean attribute from the instrument driver.

The following Attributes are supported:

SIMULATE

SYSTEM_TRACE_ENABLED

CHANNEL_AUX_OUT_ENABLED

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

SYSTEM_TRACE_ENABLED : If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. A new file is generated each time tracing is enabled.

CHANNEL_AUX_OUT_ENABLED : Set this property to true to switch the currently selected input port of the channel to auxillary output port of the digitizer. A true setting is not allowed in AgM9216MeasurementModeSingle mode.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9216.lvlib:GetAttributeViInt32.vi

GetAttributeViInt32

Gets an Int32 attribute from the instrument driver.

The following Attributes are supported:

SYSTEM_SLOT_NUMBER

CHANNEL_COUNT

CHANNEL_BANKID

TRIGGER_MODE

MEASUREMENT_MODE

CHANNEL_RECORD_SIZE

CHANNEL_INPUT_PORT

CHANNEL_INPUT_CONNECTOR_SELECTION

TRIGGER_HOLD_OFF_COUNT

TRIGGER_TIME_OUT

TRIGGER_PRE_TRIGGER_SAMPLES

TRIGGER_DELAY

TRIGGER_SLOPE

MEASUREMENT_RANGE_SELECT

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

SYSTEM_SLOT_NUMBER : Returns the the slot number of the card.

CHANNEL_COUNT : Number of Channel.

CHANNEL_BANKID : In multichannel mode this property returns the bank number of the specified digitizer(channel). In Single Channel mode, there is only one logical digitizer channel, the value returned is always 0.

TRIGGER_MODE : Sets the trigger mode either Channel (0) or Immediate (1).

MEASUREMENT_MODE : Sets the measurement mode either Single(0) or Multiple(1).

CHANNEL_RECORD_SIZE : Sets the acquisition recordSize of the Input connector of the channel.The allowable range is from 0 to 30000 in Multiple Channel and 0 to 240000 in Single Channel mode. Reset value is 5000.

CHANNEL_INPUT_PORT : The active (physically switch) port number(1 to 32) belonging to the channel (digitizer).

CHANNEL_INPUT_CONNECTOR_SELECTION : Sets the input connector.In Multiple mode, there are four (1 to 4) input connectors for each channel while in Single mode there are thirty two (1 to 32) connectors.

TRIGGER_HOLD_OFF_COUNT : Sets the count of valid edges that are detected before triggering is achieved.The allowable range is from 1 to 255.Reset value is 1.

TRIGGER_TIME_OUT : Sets the maximum time allowable to achieve trigger.The allowable range is from 1 to 16000000 us (16 s).Reset value is 1000000 us (1 s).

TRIGGER_PRE_TRIGGER_SAMPLES : Specifies the number of samples that must be collected before a trigger event will be recognized.The allowable range is from 0 to RecordSize.Reset value is 0.

TRIGGER_DELAY : Sets the trigger hold off time.The allowable range is from 0 to 16000000 us.Reset value is 0 us.

TRIGGER_SLOPE : Sets the edge type for the trigger.

Positive : Configures trigger on the Positive slope.

Negative : Configures trigger on the Negative slope.

Both : Configures trigger on the both.

Level : Configures trigger on the DC level slope.

MEASUREMENT_RANGE_SELECT : Selects which waveform data from the 5V and 100V sub channels of the digitizer will be fetched to the driver after completing acquisition

0 : MeasurementRangeSelectLow

1 : MeasurementRangeSelectHigh

2 : MeasurementRangeSelectBoth

3 : MeasurementRangeSelectNone

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9216.lvlib:GetAttributeViReal64.vi

GetAttributeViReal64

Gets a Real64 attribute from the instrument driver.

The following Attributes are supported:

TRIGGER_LEVEL

TRIGGER_HYSTERESIS

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

TRIGGER_LEVEL : Sets the trigger level in voltage for the current selected connector.The allowable range is from 0.0 V to 100.0 V.Reset value is 1.0 V.

TRIGGER_HYSTERESIS : Sets the trigger level hysteresis in voltage for the currently selected connector.The allowable range is from 0.0 V to 0.5 V.Reset value is 0.0001 V.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

idbl

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9216.lvlib:GetAttributeViString.vi

GetAttributeViString

Gets a String attribute from the instrument driver.

The following Attributes are supported:

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_VENDOR

SPECIFIC_DRIVER_REVISION

LOGICAL_NAME

IO_RESOURCE_DESCRIPTOR

DRIVER_SETUP

SUPPORTED_INSTRUMENT_MODELS

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

SYSTEM_SERIAL_NUMBER

SYSTEM_DRIVER_REVISION

SYSTEM_BOARD_REVISION

SYSTEM_CALIBATION_DATE

SYSTEM_FPGA_REVISION

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

The following attributes are supported.

SPECIFIC_DRIVER_DESCRIPTION : Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_VENDOR : Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_REVISION : Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

LOGICAL_NAME : Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

IO_RESOURCE_DESCRIPTOR : The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

DRIVER_SETUP : The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

SUPPORTED_INSTRUMENT_MODELS : A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

INSTRUMENT_FIRMWARE_REVISION : The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

INSTRUMENT_MANUFACTURER : The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

INSTRUMENT_MODEL : The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

SYSTEM_SERIAL_NUMBER : READ ONLY. The module serial number.

SYSTEM_DRIVER_REVISION : READ ONLY.Returns the fundamental driver revision.

SYSTEM_BOARD_REVISION : READ ONLY.Returns the PCB version.

SYSTEM_CALIBATION_DATE : READ ONLY.Returns the Calibration Date from EEPROM.

SYSTEM_FPGA_REVISION : READ ONLY.Returns the FPGA firmware version.

ci32

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


Agilent M9216.lvlib:Set Delay.vi

Set Delay

Sets the trigger hold off time.

Agilent M9216.lvlib:Set Delay.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

Delay

Hold off time.

Min: 0

Default: 0

Max: 16000000

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Hold Off Count.vi

Set Hold Off Count

Sets the count of valid edges that are detected before triggering is achieved. Maximum allowable is 255

Agilent M9216.lvlib:Set Hold Off Count.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

HoldOffCount

Sets the count of valid edges that are detected before triggering is achieved.

valid range are :

Min: 1

Default: 1

Max: 255

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Hysteresis.vi

Set Hysteresis

Sets the trigger level hysteresis in voltage for the currently selected connector

Agilent M9216.lvlib:Set Hysteresis.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

cdbl

Hysteresis

Sets the trigger level hysteresis in voltage for the currently selected connector.

Min: 0

Default: 0.0001

Max: 0.5

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Input Connector Selection.vi

Set Input Connector Selection

Set the Input connector of a channel (Digitizer).

Agilent M9216.lvlib:Set Input Connector Selection.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

InputConnectorSelection

In Multiple mode, there are four (1 to 4) input connectors for each channel while in Single mode there are thirty two (1 to 32) connectors.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Input Port.vi

Set Input Port

Sets the active (physically switch) port number belonging to the channel (digitizer). Port value is integer of 1 to 32.

Agilent M9216.lvlib:Set Input Port.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

InputPort

Physically switch port number (1 to 32) belonging to the digitizer.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Level.vi

Set Level

Sets the trigger level in voltage for the current selected connector.

Agilent M9216.lvlib:Set Level.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

cdbl

Level

Returns the trigger level in voltage for the current selected connector.

Min: 0.0

Default: 1.0

Max: 100.0

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Measurement Mode.vi

Set Measurement Mode

Sets the Measurement mode (Single channel) or (Multiple Channel).

Agilent M9216.lvlib:Set Measurement Mode.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

MeasurementMode

Set the Measurement mode - Single or Multiple.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Pre Trigger Samples.vi

Set Pre Trigger Samples

Specifies the number of samples that must be collected before a trigger event will be recognized. This value must not exceed the RecordSize of the waveform.This setting is ignored if TriggerMode is AgM9216TriggerModeImmediate.

Agilent M9216.lvlib:Set Pre Trigger Samples.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

PreTriggerSamples

Sets the pre trigger samples

Min: 0

Default: 0

Max: RecordSize

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Record Size.vi

Set Record Size

Sets the acquisition recordSize of the Input connector of the channel (digitizer).

Agilent M9216.lvlib:Set Record Size.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

RecordSize

Set the acquisition recordSize of the Input connector of the Digitizer, Allowable setting.

Min: 0

Default: 5000

Max: 30000 ( Multiple Channel mode )

Max: 240000 ( SingleChannel mode )

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Slope.vi

Set Slope

Sets the edge type for the trigger.

Agilent M9216.lvlib:Set Slope.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

Slope (Positive)

Sets the edge type for the trigger.

Positive : Configures trigger on the Positive slope.

Negative : Configures trigger on the Negative slope.

Both : Configures trigger on the both.

Level : Configures trigger on the DC level slope.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Time Out.vi

Set Time Out

Sets the maximum time allowable to achieve trigger. The resolution is 1 us

Agilent M9216.lvlib:Set Time Out.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

TimeOut (us)

Set the maximum time allowable to achieve trigger. The resolution is 1 us.

Min: 0

Default: 1000000 (1 s)

Max: 16000000 (16 s)

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Set Trigger Mode.vi

Set Trigger Mode

Sets the M9216A in immediate or trigger(Channel) mode.

Agilent M9216.lvlib:Set Trigger Mode.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

TriggerMode (Channel)

Sets the trigger mode

Channel : Each channel waits for a valid trigger from its source signal before acquiring data..

Immediate : Channels start waveform aquisiton immediately

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Configure.vi

Configure

This function allows the user to configure any of the input ports that belongs to this channel. InputPort does not have to be the currently selected port. The M9216A allows each input port to have a unique configuration. When the user selects an input port for acquistion, using the InputPort (or InputConnector) property, the digitizer channel will automatically be configured with the port's configuration.Note that if the InputPort does not belong to the channel , an error code will be returned.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

InputPort

The input port to configure. Must be a valid port for the channel.

ci32

RecordSize

Sets the number of samples to acquire for the waveform. This property applies for the currently selected port. To set the record length for a port that is not currently selected , use the Configure function.

cdbl

Level

Specifies the voltage threshold for the trigger sub-system. The units are Volts.Note that this setting is ignored if TriggerMode is AgM9216TriggerModeImmediate.

cdbl

Hysteresis

Specifies the trigger hysteresis in Volts. Note that this setting is ignored if TriggerMode is AgM9216TriggerModeImmediate.

ci32

HoldOffCount

Specifies the number of valid edges to detect before waveform recording can occur.Note that this setting is ignored if TriggerMode is AgM9216TriggerModeImmediate

ci32

TimeOut

Specifies the maximum allowable time for the channel to detect a valid trigger condition as specified by the configuration parameters. If the trigger condition is not met, a AgM9216AcquisitionStatusTimeOut is returned as acquisition status.The units are set in multiples of one microsecond.This setting is ignored if TriggerMode is AgM9216TriggerModeImmediate.

ci32

PreTriggerSamples

Specifies the number of samples that must be collected before a trigger event will be recognized. This value must not exceed the RecordSize of the waveform.This setting is ignored if TriggerMode is AgM9216TriggerModeImmediate.

ci32

Delay

Specifies the length of time from the valid trigger event to the first point in the waveform record. The units are seconds. The hardware resolution is microsecond and the driver will store the value closest to the hardware resolution. See example code in Remarks section.Note that this setting is ignored if TriggerMode is AgM9216TriggerModeImmediate

ci32

Slope (Positive)

Specifies trigger slope for the input port as either rising edge, falling edge ,both edges or DC level.Valid values are AgM9216TriggerSlopePositive , AgM9216TriggerSlopeNegative, AgM9216TriggerSlopeBoth and AgM9216TriggerSlopeLevel .This setting is ignored if TriggerMode is AgM9216TriggerModeImmediate.

Positive : Configures trigger on the Positive slope.

Negative : Configures trigger on the Negative slope.

Both : Configures trigger on the both.

Level : Configures trigger on the DC level slope.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Get Status.vi

Get Status

This function can be used to check the acquisition status of the digitizer?s channel. The status can any of the following as shown in table below:

(0)"AgM9216AcquisitionStatusIdle": The channel is idle. No acquisition has been initiated.

(1)"AgM9216AcquisitionStatusBusy": The channel is still in the process of looking for a trigger or still aquiring data.

(2)"AgM9216AcquisitionStatusCompleted": The acquisiton has completed successfully.

(3)"AgM9216AcquisitionStatusTimeOut": Applicable when trigger mode is set to AgM9216TriggerModeChannel. The acquisition has failed because a valid trigger was not received during within the specified time out period. No data will be available from the channel(s) that had a timeout.

Agilent M9216.lvlib:Get Status.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

ValBufferSize

Number of elements in Val.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

i1di32

Val

(0)"AgM9216AcquisitionStatusIdle": The channel is idle. No acquisition has been initiated.

(1)"AgM9216AcquisitionStatusBusy": The channel is still in the process of looking for a trigger or still aquiring data.

(2)"AgM9216AcquisitionStatusCompleted": The acquisiton has completed successfully.

(3)"AgM9216AcquisitionStatusTimeOut": Applicable when trigger mode is set to AgM9216TriggerModeChannel. The acquisition has failed because a valid trigger was not received during within the specified time out period. No data will be available from the channel(s) that had a timeout.

  1. ii32

            Numeric

ii32

ValActualSize

Actual number of elements in Val.


Agilent M9216.lvlib:Initiate.vi

Initiate

This VI causes the M9216 to start acquiring waveform on all channels. In AgM9216TriggerModeImmediate mode, all channels will start waveform aquisiton. In AgM9216TriggerModeChannel mode, each channel will wait for a valid trigger from its source signal before acquiring data..

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Update Hardware.vi

Update Hardware

Loads the digitizer configuration and connector selection into the hardware. All changes to configuration settings and connector selection are cached in the host driver until this command is called. This command effectively synchronizes the host driver and hardware.

Agilent M9216.lvlib:Update Hardware.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Wait For Acquisition Complete.vi

Wait For Acquisition Complete

Waits until the initiated acquisition is complete. Acquisition is complete when all channel(s) have sucessfully acquired the waveform or timedout waiting for a valid trigger. If no acquisition is currently running, this function returns immediately.

Agilent M9216.lvlib:Wait For Acquisition Complete.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Fetch Waveform Int32.vi

Fetch Waveform Int32

When an acquisition for a channel has been completed successfully, acquisition data will be sent from the channel to the driver memory. The user can use this function to copy the data into the user's buffer.

Agilent M9216.lvlib:Fetch Waveform Int32.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

NoOfSamples

Specifies the number of points to be retrieved to the WaveformArray buffer.

ci32

Range (Low)

If both the low and high range data has been prefetched to the driver, his parameter selects which data range is copied to user memory.Otherwise this parameter is ignored.Valid input : AgM9216DigitizerRangeSelectLowAgM9216DigitizerRangeSelectHigh

ci32

ValBufferSize

Number of elements in Val.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

i1di32

Val

An array of waveform data.

  1. ii32

            Numeric

ii32

ValActualSize

Actual number of elements in Val.


Agilent M9216.lvlib:Fetch Waveform Real64.vi

Fetch Waveform Real64

When an acquisition for a channel has been completed successfully, acquisition data will be sent from the channel to the driver memory. The waveform's voltage can be estimated with the stored channel calibration coefficient. The user can use this function to copy the voltage waveform into the user's buffer.

Agilent M9216.lvlib:Fetch Waveform Real64.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

ci32

NoOfSamples

Specifies the number of points to be retrieved to the WaveformArray buffer.

ci32

Range (Low)

If both the low and high range data has been prefetched to the driver, his parameter selects which data range is copied to user memory.Otherwise this parameter is ignored.Valid input : AgM9216DigitizerRangeSelectLow.

LOW : Fetch only the wavefrom from 5V Range sub channel. HIGH : Fetch only the wavefrom from 100V Range sub channel.

BOTH : Fetch the wavefrom from both the 5V and 100V Range sub channels.

NONE : Do not prefetch any data.

ci32

ValBufferSize

Number of elements in Val.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

i1ddbl

Val

An array of waveform data.

  1. idbl

            Numeric

ii32

ValActualSize

Actual number of elements in Val.


Agilent M9216.lvlib:Get Channel Name.vi

Get Channel Name

Returns the channel name that corresponds to the one-based index that the user specifies.

Agilent M9216.lvlib:Get Channel Name.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

Index

A one-based index that defines which name to return.

ci32

ValBufferSize

Number of elements in Name.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.


Agilent M9216.lvlib:Reset With Defaults.vi

Reset With Defaults

This function resets the M9216. All ports and properties will be set to the default values. A UpDateHardware command will be sent. This method needs to be called once when the M9216A is first started up.

Agilent M9216.lvlib:Reset With Defaults.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Reset.vi

Reset

Places the M9216 into a known state.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Revision Query.vi

Revision Query

Retrieves revision information from the instrument.

Agilent M9216.lvlib:Revision Query.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

istr

instrument driver revision

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision property. Refer to the Specific Driver Revision property for more information.

istr

firmware revision

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision property. Refer to the Instrument Firmware Revision property for more information.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Close.vi

Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Initialize With Options.vi

Initialize With Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Agilent M9216.lvlib:Initialize With Options.vi

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

option string

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: Simulate or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

cstr

resource string

A string that specifies the instrument to connect to. This can

either be a VISA resource name (also known as a VISA address)

or an IVI session, or an IVI logical name. For PXI instruments,

a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer

can be found using the Agilent Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX(Agilent devices may not appear in NI Max).

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:Initialize.vi

Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

cstr

resource string

A string that specifies the instrument to connect to. This can

either be a VISA resource name (also known as a VISA address)

or an IVI session, or an IVI logical name. For PXI instruments,

a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer

can be found using the Agilent Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX(Agilent devices may not appear in NI Max).

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9216.lvlib:VI Tree.vi

VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.

Agilent M9216.lvlib:VI Tree.vi


Related Documentation

To access documentation related to the M9216A PXI High Voltage DAQ, use one of the following methods:

  • Browse the product CD
  • Browse the Manuals
  • Go to the product web site (www.agilent.com/find/M9216A) and browse the Manuals:
  • Start > Programs > Agilent > ProductModel: Provides links to all product documentation except for the IVI driver documentation
  • Start > Programs > Agilent IVI Drivers > ProductModel: Provides link to the product IVI driver help system
  • In context to your workflow. Click here for details.


Documentation Access


Agilent M9216.lvlib:IVI Error Converter.vi

IVI Error Converter

This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Agilent M9216.lvlib:IVI Error Converter.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

IVI error code (0)

Error code returned from an IVI instrument driver operation.

cu32

instrument handle

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

  1. ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iu32

instrument handle out

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None